Pending deposits and withdrawals
Incident Report for
Bitonic
Resolved
The issue has been resolved and withdrawals and deposits are being processed.
Posted
Apr
01
,
2025
-
13:10
CEST
Identified
We are aware of an issue causing deposits and withdrawals to remain pending. Our team is actively working on a fix!
Posted
Apr
01
,
2025
-
10:25
CEST
This incident affected: Bitonic.nl website and Bitonic app.
×
Subscribe to Incident
Subscribe to updates for
Pending deposits and withdrawals
via . You'll receive .