Bitcoin withdrawals delayed

Incident Report for Bitonic

Resolved

This incident has been resolved.
Posted Dec 02, 2025 - 10:26 CET

Investigating

Bitcoin withdrawals are temporarily delayed.
Posted Nov 29, 2025 - 17:29 CET
This incident affected: Processing of deposits and withdrawals.