Outage third party service provider
Incident Report for Bitonic
Resolved
Technical difficulties resolved
Posted Oct 16, 2024 - 17:40 CEST
Identified
We are currently experiencing technical difficulties, and logging in is temporarily unavailable due to issues. We are working hard to resolve the issue as quickly as possible.
Posted Oct 16, 2024 - 16:20 CEST
This incident affected: Bitonic.nl website and BL3P.