Pending deposits and withdrawals

Incident Report for Bitonic

Resolved

This incident has been resolved.
Posted Mar 11, 2025 - 16:59 CET

Identified

We are aware of an issue causing deposits and withdrawals to remain pending. Our team is actively working on a fix!
Posted Mar 11, 2025 - 16:46 CET
This incident affected: Bitonic.nl website and Bitonic app.